PHRASEANET Abies - v4.0.8

INSTALL

Please have a look a this recommendations

Binaries requirements

OK PHP CLI is required to run Phraseanet task manager
OK Phraseanet requires the Unix `file` command
OK Exiftool is required for reading, writing and editing meta information
OK Exiftool version 9.15 or higher is required (10.10 provided)

Binaries recommendations

OK Phraseanet recommends `file` version 5.04 or higher
WARNING SWFTools are required for documents (Word, Excel, PDF, etc...) support Please install SWFTools (http://www.swftools.org/)
OK Unoconv is required for documents (Word, Excel, etc...) support
OK Unoconv version 0.5 or higher is required (0.7 provided)
OK SWFTools (swfextract) are required for flash files support
OK SWFTools (swfextract) version 0.9.0 or higher is required (0.9.2 provided)
OK SWFTools (swfrender) are required for flash files support
OK SWFTools (swfrender) version 0.9.0 or higher is required (0.9.2 provided)
OK MP4Box is required for video support
OK MP4Box version 0.4.0 or higher is required (0.5.2 provided)
OK XPDF is required for PDF indexation
OK FFMpeg (or libav-tools) is required for Video processing
OK FFProbe (or avprobe) is required for Video processing

Filesystem requirements

OK /var/www/Phraseanet/config directory must be writable
OK /var/www/Phraseanet/config/stamp directory must be writable
OK /var/www/Phraseanet/config/status directory must be writable
OK /var/www/Phraseanet/config/minilogos directory must be writable
OK /var/www/Phraseanet/config/templates directory must be writable
OK /var/www/Phraseanet/config/topics directory must be writable
OK /var/www/Phraseanet/config/wm directory must be writable
OK /var/www/Phraseanet/logs directory must be writable
OK /var/www/Phraseanet/tmp directory must be writable
OK /var/www/Phraseanet/tmp/locks directory must be writable
OK /var/www/Phraseanet/tmp/caption directory must be writable
OK /var/www/Phraseanet/tmp/lazaret directory must be writable
OK /var/www/Phraseanet/tmp/download directory must be writable
OK /var/www/Phraseanet/cache directory must be writable
OK /var/www/Phraseanet/www/custom directory must be writable

Filesystem recommendations

Locales requirements

OK intl extension should be available

Locales recommendations

OK intl extension should be correctly configured
OK intl ICU version should be at least 4+

PHP requirements

OK date.timezone setting must be set
OK detect_unicode must be disabled in php.ini
OK safe_mode must be disabled in php.ini
OK detect_unicode must be disabled in php.ini
OK file_uploads must be enabled in php.ini
OK session.cache_limiter must be disabled in php.ini
OK magic_quotes_gpc must be disabled in php.ini
OK magic_quotes_runtime must be disabled in php.ini

PHP recommendations

OK short_open_tag should be disabled in php.ini
OK register_globals should be disabled in php.ini
OK session.auto_start should be disabled in php.ini
OK display_errors should be disabled in php.ini
OK display_startup_errors should be disabled in php.ini
OK allow_url_fopen should be enabled in php.ini
OK session.hash_bits_per_character should be at least 6
OK session.hash_function should be enabled in php.ini
OK session.use_only_cookies should be enabled in php.ini
OK session.use_cookies should be enabled in php.ini
OK session.cookie_http_only should be enabled in php.ini
OK session.cookie_secure should be enabled in php.ini, but only if you use HTTPS

System requirements

OK PHP version must be at least 5.5.0 (7.0.33-0ubuntu0.16.04.3 installed)
OK Vendor libraries must be installed
OK date.timezone setting must be set
OK Configured default timezone "Australia/Melbourne" must be supported by your installation of PHP
OK json_encode() must be available
OK session_start() must be available
OK ctype_alpha() must be available
OK token_get_all() must be available
OK simplexml_import_dom() must be available
OK detect_unicode must be disabled in php.ini
OK PCRE extension must be available
OK PHP-XML module should be installed
OK mb_strlen() should be available
OK iconv() should be available
OK exif extension is required
OK curl extension is required
OK gd extension is required
OK hash extension is required
OK proc_* functions are required
OK Socket extension is required for task manager
OK Zip extension is required for download
OK ZMQ extension is required.
OK utf8_decode() should be available
OK PDO should be installed
OK PDO should have MySQL driver installed (currently available: mysql)

System recommendations

OK You should not use PHP 5.4.0 due to the PHP bug #61453
OK PCRE extension should be at least version 8.0 (8.38 installed)
OK Posix extension is recommended for task manager
WARNING Twig extension is strongly recommended in production Install and enable the twig extension.
OK Imagick or Gmagick extension is strongly recommended for image processing
OK Fileinfo extension is recommended
OK posix_isatty() should be available
OK ftp extension is required for FTP export
OK a PHP accelerator should be installed
OK short_open_tag should be disabled in php.ini
OK magic_quotes_gpc should be disabled in php.ini
OK register_globals should be disabled in php.ini
OK session.auto_start should be disabled in php.ini